19 June 2010

Erlide update site upgraded

The regular update site at http://erlide.org has been updated to the now not so new p2 update manager format. Only the latest 0.8.3 build is available there.

Older stable releases are to be found at http://erlide.org/update_classic, if you need one of those.

This is so that we can appear on the Eclipse marketplace, which will be integrated in Eclipse in the upcoming 3.6 version.


Erik Søe Sørensen said...

Could the documentation on http://erlide.sourceforge.net/#installation please be updated?
The ErlIDE repository does not seem to work well for Eclipse 3.5.1; I think it might be an idea to provide a pointer to the older releases.

And regarding that, http://erlide.org/update_classic does not work for me either - I get "No repository found" :-|

Erik Søe Sørensen said...

http://erlide.org/update_classic doesn't work - but http://erlide.org/update_old does :-)
(Works for Eclipse 3.5.1 where the current version doesn't.)

Vlad said...


I will look at that, thanks for pointing it out!

What exactly is the problem with the http://erlide.org/update site? Do you have an error message or log?

The *_old (née *_classic) repository is providing very old versions, there's a lot that happened since then.

Erik Søe Sørensen said...

The error message was something to do with org.eclipse.core.filesystem...:
When I try to install the current version now, I get this (and apart from the first bit, it looks like what got before):

Your original request has been modified.
"Erlide core (headless)" is already installed, so an update will be performed instead.
"Erlang IDE" is already installed, so an update will be performed instead.
Cannot complete the install because of a conflicting dependency.
Software being installed: Erlang IDE (org.erlide.feature.group
Software currently installed: Eclipse Platform 3.5.1 (Eclipse Platform 3.5.1)
Only one of the following can be installed at once:
Core File Systems 1.2.0.v20090507 (org.eclipse.core.filesystem 1.2.0.v20090507)
Core File Systems 1.2.1.R35x_v20091203-1235 (org.eclipse.core.filesystem 1.2.1.R35x_v20091203-1235)
Cannot satisfy dependency:
From: Eclipse Platform 3.5.1 (Eclipse Platform 3.5.1)
To: org.eclipse.core.filesystem [1.2.0.v20090507]
Cannot satisfy dependency:
From: Erlang IDE (org.erlide.feature.group
To: org.erlide.headless.feature.group []
Cannot satisfy dependency:
From: Erlide core (headless) (org.erlide.headless.feature.group
To: org.eclipse.core.filesystem 1.2.1

Vlad said...

Aha, I see. It looks like from 0.11 we specified a dependency on plugins from 3.5.2 -- Eclipse uses the value from one's current environment.

I fixed this for the next release. In the meanwhile, maybe you can upgrade to Eclipse 3.5.2? Some time after 3.7 is released we will probably drop support for 3.5 anyway.